неофициальный блог

Замечательные возможности Skype

Skype для Web стал доступен всем пользователям

Сегодня стало известно что Skype для Web больше не находится в стадии закрытой тестировании, а перешёл к новой стадии — открытое бета-тестирование. Таким образом, больше не существуют ограничения, и пользователи со всего мира могут тестировать сервис Skype для Web — для этого им понадобится лишь браузер и подключение к Интернету.

Однако нужно отметить, что для голосовых и видеозвонков необходимо установить специальный плагин для браузера, который в дальнейшем он будет сам автоматически обновляться. Более того, так как данный плагин доступен только для операционных систем Windows и Mac OS, совершать голосовые и видеозвонки смогут только пользователи этих ОС.

С помощью Skype для Web пока нельзя отправить и получать файлы. При попытке отправить такому пользователю файл (кроме изображений), он получит сообщение «Получение файлов не поддерживается Skype для браузера». А вот изображения показываются и возможно, в скором временем станет доступна полноценная функция обмена файлами.

Пока многие функции недоступны в Skype для Web, но разработчики говорят, что они много работают над его улучшением и будут добавить в Скайп для браузера все привычные функции и возможности.

Чтобы запустить Skype для Web, переходите на этой странице: https://web.skype.com/ru/

17 комментариев

  1. 1 +1 0
    Александр,
    Плагин Skype для Web не устанавливается на Windows XP!
    1. 1 +1 0
      Администратор,
      Вы правы — при попытке установить появляется ошибка «Сбой установки: для Подключаемый модуль Skype для бизнеса Web Арр требуется Windows 7 или более поздней версии». Так что, увы, невозможно установить плагин на Windows XP или Vista.
      1. 1 +1 0
        Александр,
        Значит, Skype для Web в Windows XP использовать невозможно... В Windows XP нужно или пользоваться обычным скайпом, или менять Windows XP на более новую систему, что для меня пока что нереально...
  2. 2 +2 0
    carrier lost,
    Погуглил самые первые версии плагина. Нашел три версии: 7.2.0.422 (от 09.04.2015), 7.1.0.63 (от 27.11.2014) и 7.0.1.58 (от 22.10.2014). Ниже и между уже ничего не гуглится. При этом версия 7.0.1.58, в отличие от остальных, скачивается уже по ссылке без цифр:

    https://swx.cdn.skype.com/plugin/7.2.0.422/SkypeWebPlugin.msi
    https://swx.cdn.skype.com/plugin/7.1.0.63/SkypeWebPlugin.msi
    https://swx.cdn.skype.com/plugin/SkypeWebPlugin.msi

    Т.е. по всей видимости 7.0.1.58 - это и есть самая первая публичная версия.

    И она ставится под XP (ставится сразу, без предупреждений, в папку Documents and Settings\%User%\Local Settings\Application Data\SkypePlugin, никаких ярлыков при это не создается, удаление через "Установка и удаление" - "Skype Web Plugin"). Но при активации в браузере эта версия крашится, видимо потому, что в XP-шном kernel32.dll отсутствует одна необходимая файлу PluginHost.exe инструкция.

    Скорее всего разработчики просто забыли запретить совместимость с XP при компилировании дистрибутива, потому что уже следующая версия 7.1.0.63 требует Windows Vista SP2 и выше, а 7.2.0.422 Windows 7.
    1. 1 +1 0
      Администратор,
      Спасибо за интересную и полезную информацию. Как я понимаю, Вам не удалось "обмануть" плагин и запустить его на Windows XP? Как думаете, если написать хук для kernel32.dll, возможно ли заставить плагин работать на этой ОС? Или может, ещё легче — просто скопировать kernel32.dll из Vista?
      1. 0 0 0
        carrier lost,
        Мне кажется нет смысла с этим заморачиваться, т.к. эта первая версия уже безнадежно устарела, а в остальных неподдерживаемых функций намного больше. Я просто для информации отправил этот пост. Нет, не удалось, и не пытался.
        1. 1 +1 0
          Администратор,
          Понял, спасибо за ответ. Я подумал, возможно первые версии плагина работали на Windows XP и в отличие от десктопного приложения не требовали SSE2. Если это было бы так, чтобы совершать видеозвонки на старых компьютерах можно использовать плагин.
          1. 1 +1 0
            carrier lost,
            Нет, проверил, у меня как раз старый комп без SSE. В Virtual PC под Vista SP0 (больше тестить не на чем) 7.0.1.58 тоже крашится. С kernel32.dll тут проблем нет, но Dependency Walker показывает отсутствующие функции в каких-то двух других файлах. Но причина думаю не в них, а именно в том, что мой проц не поддерживает SSE2 (и SSE тоже). Вообще-то скайп перешел на SSE2 еще с версии 6.2.0.106 (от 07.02.2013) и я не думаю, что спустя больше чем 1,5 года, разработчики стали бы делать откат в прошлое и что-то компилировать без SSE.

            А что касается видеозвонков, то они работают в версиях до 6.2.0.106, т.е. 6.1.999.130 от 24.01.2013 (специальный последний билд для nonSSE компов, который был выложен на http://www.skype.com/go/getskype-sse) и ниже. У вас на сайте этого билда вроде нет, но можно использовать 6.1.60.129 от 08.01.2013 (в чем их отличие я не в курсе).

            Только отдельно я эти старые версии не ставлю, поэтому не знаю как там будет с авторизацией (насколько я помню после 01.08.2014 в версиях, выпущенных до 2014 года авторизация невозможна). У вас на сайте описан способ по запуску версии 5.7 http://www.skaip.su/html-tegi-v-chate-skype, но он какой-то муторный.

            Можно просто распаковать дистрибутив по SkypeSetupFull.exe /extractonly:"c:\123", достать из Program Files\Skype\Phone файл Skype.exe и запускать через него, параллельно с установленной поддерживаемой версией (т.е. выпущенной после 2013 года). На работоспособности это вроде никак не сказывается (запускаю так даже версию 5.5 параллельно с 6.16, и все работает, хотя насчет связки 7.x/5.x не уверен).

            Можно кинуть экзешник прямо в C:\Program Files\Skype\Phone, переименовав его в Skype6.1.exe, например, сделать на него ярлык и пользоваться, когда нужна видеосвязь (или html-теги, например, которые поддерживаются, как у вас написано, в версиях до 5.8, версию 5.5 держу как раз ради них).

            Только на XP все равно возможны вылеты во время авторизации. Если это происходит, нужно переименовать файл C:\WINDOWS\system32\drivers\amdfix.sys в amdfix.sys.old и перезагрузиться (мне помогло). Актуально для версий ниже 6.2.0.106. Или существует способ с пропатчиванием экзешника, который по-моему решает проблему и с авторизацией и с amdfix (если это вообще разные проблемы, т.к. патченная таким образом 5.5 у меня работала и без переименования amdfix.sys).

            Суть его - в подмене номера версии внутри Skype.exe на одну из выпущенных после 2013 года. Но он подходит только для деобфусцированных (распакованных) экзешников, т.к. в нераспакованных строки с номером версии будут зашифрованы, и патчить будет нечего. А такие распакованные экзешники существуют только для версий 3.8, 4.2, 5.5, 5.9 и 6.16 (не считая совсем старые версии). Хотя у авторов можно заказать распаковку и других версий, за плату. Погуглите skypeopensource blogspot, если интересно.

            Кстати, видеозвонки тестировал пока только с человеком, у которого установлена версия Skype 4.17.135 (начало 2014 года) на iPhone 4S. С последними мобильными/десктопными версиями пока неизвестно, есть ли у них обратная совместимость со старыми версиями или нет.

            И еще такой минус, что на старых версиях (до 6.5 Beta), нельзя скрыть IP от Skype-резолверов, нет такой опции в настройках...
            1. 0 0 0
              Администратор,
              Спасибо большое! Снимаю шляпу за столь развёрнутый ответ. Только сейчас понял, что уже видел другие полезные комментарии от одного «пирога» ;)

              Я тоже подумал написать нормальную инструкцию о том, как запустить старые версии Скайпа. Правда, без использования патченных версий, ибо не хочется подвергать пользователей риску заражения компьютера (к тому же, учитывая, как на официальном форуме относятся к подобным вещам, не хочется «сюрпризов»). Именно поэтому, отдельно благодарю за описание метода запуска старых версий.

              ps. Учитывая Ваш опыт и знания, а также то, что у Вас есть компьютер со старым процессором без SSE2, в случае необходимости, могу ли я обратиться к Вам за помощи или советом?
            2. 0 0 0
              Сергей,
              А у меня тоже Windows XP без обновлений, но даже нет такого файла (amdfix.sys.). Вообще да, хотелось бы найти способ пользоваться скайпом (видео и аудиоз звонками), не прибегая к установке или обновлению ОС, лично мне. Я особо не разбираюсь во всём этом, Прежде чем обновиться до SP2 (у меня 64-бит), надо знать различные нюансы, как создавать резервную копию всего и т.д. А устанавливать новую нет возможности пока.
              Клиент новый не загружается, понятно почему, а старый клиент пишет "не удаётся выполнить соединение", и для того чтобы устранить эту проблему, нужна новая версия. Замкнутый круг.
              Правда, я ещё не пробовал звонить и разговаривать по браузерной версии, но уже установил старый плагин, ссылку которого Вы выше оставили, за что Вам спасибо.
              И спасибо Администратору данного сайта и автору статей за ответы на вопросы и за поиск решения проблем!
  3. 0 0 0
    Алишер,
    Всё что описано - похоже на мои "болячки", но у меня ничего не получилось.
  4. 0 0 0
    Рустем Галимов,
    Skype не загружается и не включается .Что делать . Подскажите пожалуйста
    1. 0 0 0
      Администратор,
      Здравствуйте! Укажите, Вашу операционную систему, версию Skype и точный текст ошибки.
  5. 0 0 0
    Рустем Галимов,
    не могу выйти на контакт и на связь
    1. 0 0 0
      Администратор,
      Здравствуйте! Укажите, пожалуйста, больше подробности о Вашей системе и что именно не получается.
  6. 0 0 0
    Анатолий,
    Обновил на висте скайп, теперь не проходят звонки. Выходит сообщение :для подключаемый веб-модуль скайп требуется виндоус 7 или более поздней версии.
    Помогите советом, только попроще. Я не продвинутый юмор и компилировать файлы не умею.
    1. 0 0 0
      Администратор,
      Здравствуйте! Боюсь, Skype для Web не поддерживает Windows Vista. Рекомендую скачать Скайп для Windows.

Добавить новый комментарий

Комментарии проверяются администратором и могут не сразу появляться на сайте.
Имя:
Емайл:
Подписаться на новые комментарии
Сообщение:
Оценка страницы: